hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: Java Version Compatiblity
Date Wed, 06 Jan 2010 22:26:07 GMT
Luke Pillow wrote:
> Hello,
> 
> I'd like to use the HTTPClient, but I'm restricted to Java 1.4.2.
> 
> Is 3.1 compatible with Java 1.4.2?

HttpClient 3.x requires Java 1.2.2

> Is 4.x compatible with Java 1.4.2?
>

HttpClient 4.x requires Java 1.5.0. However, HttpCore - a set of low 
level transport components HttpClient is based on - requires Java 1.3.0 
only. You are likely to have to write more code in order to get things 
done, though:

http://hc.apache.org/httpcomponents-core/index.html
http://hc.apache.org/httpcomponents-core/tutorial/html/index.html
http://hc.apache.org/httpcomponents-core/examples.html

Hope this helps

Oleg

> Thanks,
> Luke.
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message