hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From TimJim <timhei...@att.net>
Subject Problem with AJAX/JSON calls
Date Sat, 28 Mar 2009 17:30:09 GMT

Hi,

This has me stumped -- any help would be appreciated.

I am writing a load agent to hit a web application that uses AJAX/JSON 
calls.


>From the browser I get:

Get mainPage  --- > returns an HTML form
Post mainPage/getData --->  returns a JSON object

>From the Agent which uses HTTPClient

Get mailPage ---> returns the same HTML page
POST MainPage/getData ---> returns an HTML page that looks like the 
original one

I have verified that the enclosed payload on the POSTs are identical and 
all headers are identical (except for a ASP authentication token stored 
as a cookie, which is caught internally by HTTPClient.  This  appears to 
vary but does not create any problems with any of the other page calls).

The only thing I can think of is that some connection is being closed 
that should not be (or vice-versa)

Both requests have a "Connection: Keep-Alive" header and the POSTs have 
a "Content-Type:  application/json" header.

I have no easy access to the third-party server-side application.

Tim


-- 
View this message in context: http://www.nabble.com/Problem-with-AJAX-JSON-calls-tp22759347p22759347.html
Sent from the HttpClient-User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message