hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ilhami visne <ilhami.vi...@gmail.com>
Subject Re: can't fake the web server anymore, while setting the USER_AGENT...
Date Tue, 15 Jul 2008 11:32:41 GMT
Yes, i did. It works in a browser.

I'm using now HttpClient v4-Alpha. i had to change lot of codes and now 
somehow it works.

thank you again.

neil al wrote:
> Have you tried opening the site on a normal browser(i.e. Firefox and IE)?
>
> On Thu, Jul 10, 2008 at 8:58 PM, Ilhami Visne <ilhami.visne@gmail.com>
> wrote:
>
>   
>> Hi All,
>>
>> I extract some infos from a website. This website checks the browser
>> type of the user. If it is not a wellknown browser like firefox,ie
>> etc., it gives an error message like your browser doesn't support
>> frames.
>>
>> I set my user agent as this:
>> getmethod.getParams().setParameter(HttpClientParams.USER_AGENT,
>> "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)");
>>
>> This way my program ran for almost 2 years without a problem. But
>> today it simply didn't work. I think, somehow the web server guess
>> right my browser( HTTPClient), because i get the error "your browser
>> doesn't support ....".
>>
>> Has the web server now become smarter? How can i let it believe that i
>> am using e.g. firefox?
>>
>> thanx.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
>> For additional commands, e-mail: httpclient-users-help@hc.apache.org
>>
>>
>>     
>
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message