hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From adam_j_bradley <adam_j_brad...@yahoo.com>
Subject Q: Issues when attempting to send "&gt". Wind up with "&amp;gt;"
Date Tue, 15 Apr 2008 17:23:55 GMT

I'm currently setting this string (which forms part of the WSSecurityHeader),
however, when I try and use "&gt;" I wind up with "&amp;gt;".

---snip---
<ppSoapHeader25>&lt;s:ppSoapHeader
xmlns:s="http://url/SoapServices/SoapHeader"
version="1.0">&lt;s:lcid>1033&lt;/s:lcid>s:sitetoken>t:siteheader
xmlns:t="http://url/SiteToken" id="253988"
/>/s:sitetoken>/s:ppSoapHeader></ppSoapHeader25>
---snip---

What I want the web service to see is 

---snip---
<ppSoapHeader25>&lt;s:ppSoapHeader xmlns:s="http://url/SoapHeader"
version="1.0"&gt;&lt;s:lcid&gt;1033&lt;/s:lcid&gt;&lt;s:sitetoken&gt;&lt;t:siteheader
xmlns:t="http://url/SiteToken" id="253988"
/&gt;&lt;/s:sitetoken&gt;&lt;/s:ppSoapHeader&gt;</ppSoapHeader25>
---snip---

Any ideas?
Thanks in advance!
Adam


-- 
View this message in context: http://www.nabble.com/Q%3A-Issues-when-attempting-to-send-%22-gt%22.-Wind-up-with-%22-amp-gt-%22-tp16703396p16703396.html
Sent from the HttpClient-User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message