hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ken MacPherson (CampusEAI Consortium)" <ken_macpher...@campuseai.org>
Subject Re: The problem with authentication on SSO
Date Sat, 15 Dec 2007 15:34:06 GMT
We use Oracle 10g & jmeter extensively.
I use iehttpheaders to check the redirects find the differences between my httpClient/jmeter
calls.
The error might be due to a port different. 10g wants the ports the same.
Oracle SSO views http://yourFQDN:443 differently than http://yourFQDN:7777
if your using a non-ssl port for accessing the servlet, then you'll get this.
have your system admin "register" the different port with the 10g SSO using 10g ssoreg utility.

goran wrote:
> I have the problem to accomplish SSL connection with servlet on Oracle AS.
> Application server is configured to use SSO for authentication. When I try
> to access servlet, AS redirect my request to SSO for authentication. As the
> result of authentication I got cookie with SSO_ID parameter, but response
> message is “ Oracle SSO Failure - Unable to process request.Either the
> requested URL was not specified in terms of a fully-qualified host name or
> OHS single sign-on is incorrectly configured. Please notify your
> administrator”
> 
> When I try the same things with same certificate and with web browser
> everything is OK.
> 
> Does anybody have experience  with authentication on SSO?
> 
> Thanks,
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-users-unsubscribe@hc.apache.org
For additional commands, e-mail: httpclient-users-help@hc.apache.org


Mime
View raw message