hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arnaud Masson <amas...@kikamedical.com>
Subject Re: [POLL] Minimal JRE for HttpClient 4.0
Date Fri, 23 Nov 2007 12:51:38 GMT
+1

(all Jakarta Commons should take advange of Java 1.5...)

Oleg Kalnichevski a écrit :
> Dear HttpClient users,
>
> HttpClient 4.0 code line currently requires Java 1.4. We are considering
> migrating HttpClient to Java 1.5, so we could take advantage of new
> language features and platform libraries (such generics, enums, and
> java.util.concurrent classes) 
>
> Please let us know what you think by casting a vote as follows:
> -------------------------------------------------------------------
> [ ] +1 I am in favor of using Java 1.5 and taking advantage 
>        of its new features
> [ ] -1 I am NOT in favor of using Java 1.5. Java 1.4 compatibility 
>        is more important
> -------------------------------------------------------------------
>
> When voting please take into consideration the following factors 
> (1) core HTTP components (released as a separate package) will remain
> Java 1.3 compatible
> (2) it will probably take a year to complete the development of
> HttpClient 4.0. By that time Java 1.5 is likely to be more pervasive
> than today    
>
> Everyone is encouraged to express his/her opinion on the matter
>
> Oleg, on behalf of the HttpComponents team
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: httpclient-user-help@jakarta.apache.org
>
>
>   



Mime
View raw message