hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Unable to parse header : HTTP/1.1 200 OK
Date Sat, 28 Apr 2007 12:50:26 GMT
On 28/04/07, Eugeny N Dzhurinsky <bofh@redwerk.com> wrote:
> On Thu, Apr 26, 2007 at 04:56:46PM +0300, Eugeny N Dzhurinsky wrote:
> > Hello!
> >
> > I understand something might be wrong for the website and the protocol might
> > be corrupted, but as soon as mozilla/IE browsers are displaying the website

The server is returning

HTTP/1.1 302
Server: Microsoft-IIS/5.0
Date: ...
Location: http://www.archchemicals.com/Fed/BIO
HTTP/1.1 200 OK

This is not valid HTTP - the last line should not be present.

> > fine, we need to get some workaround. Could you please suggest something,
> > which will not lead us to modifying Httpclient sources?

Have you tried speaking to your server administrator?

In the meantime, why not try starting at:

http://www.archchemicals.com/Fed/BIO

which does not show the same problem?

> >
> > I've read about error handling for protocol errors, but I just found it is
> > possible to force HttpClient to retry this url again and again. In such case
> > as described above this will lead to a infinite loop unless we will still
> > handle this error (which isn't an error in our case).
> >
> > We are using HttpClient 3.01 and 3.1-RC1, with same results.
>
> So is there some kind of a non-intrusive workaround for resolving such errors
> in HttpClient?

See above ...

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-user-help@jakarta.apache.org


Mime
View raw message