hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roland Weber <http-as...@dubioso.net>
Subject Re: JDK 1.5 Version of HttpClient ?
Date Fri, 03 Nov 2006 15:43:52 GMT
Hello Ranobroto,

> I am getting errors in the following package trying to compile HttpClient
> 3.0.1 with JDK 1.5 !
> 
> I have org.apache.common.codec and org.apache.commons.logging from the
> dependencies list...
> 
> Error in package:
> 
> org.apache.commons.logging.impl
> Classes in this package are looking for the following packages:
>  org.apache.avalon.framework.*
>  org.apache.log4j.*
>  org.apache.log.*
> 
> These packages are not listed in the dependencies list for HttpClient, so I
> was wondering if I am missing something here...Can someone please assist ?

These packages are not dependencies of HttpClient. Neither is
package org.apache.commons.logging.impl part of HttpClient.
Use _precompiled_ versions of commons codec and commons logging,
or add the dependencies of those components as well.

hope that helps,
  Roland

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-user-help@jakarta.apache.org


Mime
View raw message