hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugeny N Dzhurinsky <b...@redwerk.com>
Subject Re: logging
Date Mon, 03 Jul 2006 17:05:32 GMT
On Sat, Jul 01, 2006 at 01:26:40PM +0800, neil al wrote:
> here is my log4j.xml

I modified it a bit:

<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE log4j:configuration SYSTEM "log4j.dtd">
<log4j:configuration xmlns:log4j="http://jakarta.apache.org/log4j/">
    <appender name="appender" class="org.apache.log4j.ConsoleAppender">
        <param name="Threshold" value="DEBUG" />

        <layout class="org.apache.log4j.PatternLayout">
            <param name="ConversionPattern" value="%d{HH:mm:ss} [%t] %p (%c) - %m%n" />
        </layout>
    </appender>

    <category name="httpclient.wire.content">
        <priority value="INFO" />
    </category>

    <category name="org.apache.commons.httpclient.HttpParser">
        <priority value="INFO" />
    </category>

    <root>
        <priority value="debug" />
        <appender-ref ref="appender" />
    </root>
</log4j:configuration>


> Is your log4j.xml is in the classpath?

yes, it is

But still no luck - I can see debug output from my application, but I can't
see any output about HTTP headers etc.

-- 
Eugene N Dzhurinsky

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-user-help@jakarta.apache.org


Mime
View raw message