hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Cohen <sco...@javactivity.org>
Subject Re: jboss-3.2.1 and HttpClient ClassLoader issue
Date Wed, 28 Sep 2005 10:41:31 GMT
Thanks.  This is really frustrating.  I've been asking on JBoss forums 
all week and nobody will answer.

I'm not sure what you mean by "Slide".  I'm not using "Slide" as far as 
I know.  I am stuck with a commercial product that is built on top of 
JBoss 3.2.1 (which is ancient in itself) and I have no control over 
that.  JBoss 3.2.1 ships with this 1.0.16.  I'd like to get more 
information about changing the class loading in JBoss for this one 
package within my application but I can't get anyone there to answer 
that either.

I think basically, I'm screwed.  I think we are going to have to recode 
our application not to use HttpClient.  This really stinks.

Oleg Kalnichevski wrote:
> On Tue, Sep 27, 2005 at 08:09:54AM -0700, scohen@javactivity.org wrote:
> 
>>I am in a situation where I am developing an application for deployment
>>into a JBoss 3.2.1 container.  The version of JBoss is something I have
>>no control over., unfortunately.
>>
>>JBoss 3.2.1 includes commons-httpclient.jar (v 1.0.16) in its
>>{jboss-root}/lib top level directory, I believe, because 
>>Tomcat needs it.
>>
>>Meanwhile, without realizing any of the above, we have developed new
>>functionality for this application which targets HttpClient 2.0.x.  We
>>need the extra features of 2.0.  However, deploying
>>coomons-httpclient.jar in our war file's WEB-INF/lib runs into
>>InvalidClassChangeErrors when the new code is loaded - there is a
>>conflict between JBoss 3.2.1's HttpClient-1.0.16 and the 2.0 that we
>>need.
>>
>>Does anyone on this list know if there are any issues with replacing the
>>HttpClient-1.0.16 that came with JBoss-3.2.1 with a 2.0 version of
>>HttpClient in the {jboss-root}/lib directory?  Is 2.0 sufficiently
>>backward compatible with 1.0 that this will cause no problems?
>>
> 
> 
> I believe HttpClient-1.0.16 is an ancient fork of HttpClient 1.0 shipped
> with Jakarta Slide. You may consider upgrading to a newer version of
> Slide that ships with HttpClient 2.0.2
> 
> HttpClient 2.0.x is definitely not API / ABI compatible with HttpClient
> 1.0 or any of its unofficial forks
> 
> Oleg
> 
> 
> 
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
>>For additional commands, e-mail: httpclient-user-help@jakarta.apache.org
>>
>>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: httpclient-user-help@jakarta.apache.org
> 
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-user-help@jakarta.apache.org


Mime
View raw message