hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jaya Christina B." <bj...@mahindrabt.com>
Subject Versioning problem(?): Cactus 1.4.1 with HttpClient V2.0 vs V3.0
Date Wed, 06 Jul 2005 10:38:48 GMT
Hi,
We are using Cactus 1.4.1 which uses HttpClientV2.0. for running JUnits
We now wanted to use <<HttpClientV3.0>> for our other classes for talking to
external systems.

When I try to replace <<commons-httpclient-2.0-rc2.jar>> with the version
<<commons-httpclient-3.0-rc2.jar>> 
for this version upgrade, while running Junits I get the following error. 
<snip>
java.lang.VerifyError: (class:
org/apache/cactus/client/HttpClientConnectionHelper, method: 
dispatch24_connect signature:
(Lorg/apache/cactus/WebRequest;)Ljava/net/HttpURLConnection;) Bad type in
putfield/putstatic
</snip>

If I use V3.0, no error occurs during Junits compilation. But only during
running the Junits, do I get this error.

Could you please let me know if I am missing something or if this is a known
error. 
If you could give me some pointers, it would be very useful & appreciated.

Thanks a lot.
 
Regards,
Jaya.
[MBT, India]


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-user-help@jakarta.apache.org


Mime
View raw message