hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Terrell <Steven.Terr...@guideworkstv.com>
Subject RE: Unusual delay running under Microsoft Virtual PC
Date Fri, 03 Jun 2005 15:45:32 GMT
Roland,
   Thanks for the tip. I used Sun's KnockKnock client/server example to
isolate the problem to Sun Java 1.5. Sun Java 1.4 does not exhibit the
problem. But, my app uses 1.5 specific code, so I am out of luck...
   I'll report the bug to Sun.

--Steve

-----Original Message-----
From: Roland Weber [mailto:ROLWEBER@de.ibm.com] 
Sent: Friday, June 03, 2005 1:34 AM
To: HttpClient User Discussion
Subject: Re: Unusual delay running under Microsoft Virtual PC

Hello Steve,

have you tried to run a simple Java application that opens a socket
connection under Virtual PC? With the same JVM you are using for
HttpClient? I would suspect the problem there. Opening a socket
connetcion is implemented in the JVM and probably uses native
code.
If a plain Java application does not exhibit the delay you noticed
with HttpClient, we shall have to investigate. If it does, try different
JVMs, maybe only some of them have the problem.

hope that helps,
  Roland




Steven Terrell <Steven.Terrell@guideworkstv.com> 
02.06.2005 21:24
Please respond to
"HttpClient User Discussion"


To
"Httpclient-User-List (httpclient-user@jakarta.apache.org)" 
<httpclient-user@jakarta.apache.org>
cc

Subject
Unusual delay running under Microsoft Virtual PC






Platform: Red Hat Enterprise Linux WS 3, running under Microsoft Virtual 
PC
on XP

I am experiencing an unusual problem when running httpclient apps when the
host OS is running under Microsoft Virtual PC. I consistently get a 20
second delay from PostMethod.execute(). When I run the same application on 
a
'real' OS, I don't experience the delay. For testing I am using the 
PostXML
example from the HttpClient web site. Here's part of the log I captured,
which shows the 20 second delay:
2005-05-31 15:50:42  org.apache.commons.httpclient.HttpConnection DEBUG -
enter HttpConnection.open() 
2005-05-31 15:50:42  org.apache.commons.httpclient.HttpConnection DEBUG -
Open connection to xxx.xxx.xxx.xxx:8080 
2005-05-31 15:51:02  org.apache.commons.httpclient.HttpMethodBase DEBUG -
enter HttpMethodBase.execute(HttpState, HttpConnection)

My first inclination is to blame Virtual PC, but so far no other
applications have had a problem. I can run a browser from the virtual 
Linux,
and get a quick response from the same Tomcat servlet I am accessing using
PostXML.

I am not expecting a fix, but any thoughts or ideas would be welcome.

--Steve


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-user-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-user-help@jakarta.apache.org


Mime
View raw message