hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Linuxhippy <linuxhi...@web.de>
Subject Re: Question about the ssl-problem on java-1.5
Date Mon, 09 May 2005 23:43:40 GMT
Hi Oleg,

>HttpClient fully relies on JSSE to provide transport security, so this
>is very unlikely to be a bug in HttpClient. I suspect the non-blocking
>IO support for SSL in Java 1.5 required a complete rewrite of the
>underlying SSL engine, so I am not at all surprised to see compatibility
>issues.
>
Well, non blocking IO was introduced in 1.4, wasn't it.
Maybe secure non-blocking sockets were introduced in 1.5, I have to 
admit that JSSE is completly new to me.

> I would recommend to stick to Java 1.4.2 (or another stable JSSE
>implementation) for the time being.
>
I just filled out a bug report at SUN -> 3 weeks till response -> 3 
years to get things fixes :-(
I am in the sad position that I have to support what ma customers want 
to use, but for now its not too problemati to limit support to 1.4.x

Thank a lot, lg Clemens

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-user-help@jakarta.apache.org


Mime
View raw message