hc-httpclient-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sushil Sureka <sushil.sur...@gmail.com>
Subject Switiching from https to http
Date Thu, 07 Apr 2005 23:08:58 GMT
Hi,
I am trying to connect to https site and post userid/password to
authenticate and then finally download a html page. The html page is
served from a http link. So basically only userid/password page is
https and rest is http. (I think also there is some redirection going
on after you login.)
The server is running on weblogic. Anyway, I am running into problem
wher I keep getting redirected to security page. For example in my
first attempt (code snippet is below)

      PostMethod post = new PostMethod("https://localhost.com");
            post.addParameter("login", "MYUSER");
            post.addParameter("password", "XXXX");
            post.addParameter("submit", "Submit");*/
            post.setFollowRedirects(true);
            post.setStrictMode(false);
            HttpClient client = new HttpClient();
            int status = client.executeMethod(post);
  
I get This document you requested has moved temporarily.</p>
<p>It's now at <a
href="https://localhost:7002/security/loginAction.do&#59;jsessionid=CV2ZJQa52JDcwgT2wX23GrW2q9c1Tbc6SL1AQ0lckxD72ToGdR5z!212976055?password=XXXX&amp;submit=Submit&amp;login=MYUSER">https://localhost:7002/security/loginAction.do&#59;jsessionid=CV2ZJQa52JDcwgT2wX23GrW2q9c1Tbc6SL1AQ0lckxD72ToGdR5z!212976055?password=XXXX&amp;submit=Submit&amp;login=MYUSER</a>.</p>
</body></html>

Then I tried to follow the redirect 
            Header locationHeader = post.getResponseHeader("location");
            if (locationHeader != null) {
                System.out.println("redirecting to " + redirectLocation);
                post = new PostMethod(redirectLocation);
               status = client.executeMethod(post);

Again I get redirected to same url
https://localhost:7002/security/loginAction.do?password=XXX&amp;submit=Submit&amp;login=MYUSER
( this time around without jsession id)

But if I disable the HTTPS on server, I can work fine. Is there any
idea why this might be happening. The server does create a cookie
after you login but I am not even getting to that point.
thanks
Sushil

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-user-help@jakarta.apache.org


Mime
View raw message