hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oleg Kalnichevski (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HTTPCLIENT-1885) 400 Bad Request Server: Microsoft-HTTPAPI/2.0
Date Tue, 28 Nov 2017 09:53:00 GMT

    [ https://issues.apache.org/jira/browse/HTTPCLIENT-1885?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16268472#comment-16268472
] 

Oleg Kalnichevski commented on HTTPCLIENT-1885:
-----------------------------------------------

I am hoping to complete all the feature planned for 5.0 by Jan 2018 and have BETA1 released
immediately after.

Oleg

> 400 Bad Request Server: Microsoft-HTTPAPI/2.0
> ---------------------------------------------
>
>                 Key: HTTPCLIENT-1885
>                 URL: https://issues.apache.org/jira/browse/HTTPCLIENT-1885
>             Project: HttpComponents HttpClient
>          Issue Type: Bug
>          Components: HttpClient (classic)
>    Affects Versions: 5.0 Alpha3
>            Reporter: Bernhard Altendorfer
>            Priority: Minor
>              Labels: regression
>             Fix For: 5.0 Beta1
>
>
> Sending a HTTP GET to http://www.bungalow.net from Postman, cURL and HttpClient 4.5 works
and returns a 200.
> Sending the same request from HttpClient 5.0 results in a 400.
> I enabled logging and saw this difference in the response headers:
> Server: Microsoft-IIS/8.0
> Server: Microsoft-HTTPAPI/2.0
> It seems that there is some additional services listening to port 80 on new windows machines
and somehow the request from HttpClient 5.0 is forwarded to this one and not the IIS.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message