hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Release issues Re: [VOTE] Release HttpCore 5.0-beta1 based on beta1-RC1
Date Fri, 03 Nov 2017 14:07:33 GMT
On Thu, 2017-11-02 at 18:07 -0600, Gary Gregory wrote:
> 

...


> The tests need to be adjusted for:
> 
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T01:58:13-06:00)
> Maven home: C:\Java\apache-maven-3.5.2\bin\..
> *Java version: 1.8.0, vendor: IBM Corporation*
> Java home: C:\eclipse\IBM-6.4.5\ibm_sdk80\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 10", version: "10.0", arch: "x86", family:
> "windows"
> java version "1.8.0"

I'll take care of it after the release.


> Java(TM) SE Runtime Environment (build pwi3280sr4fp5-20170421_01(SR4
> FP5))
> IBM J9 VM (build 2.8, JRE 1.8.0 Windows 10 x86-32 20170419_344392
> (JIT
> enabled, AOT enabled)
> J9VM - R28_20170419_1004_B344392
> JIT  - tr.r14.java_20170419_344392
> GC   - R28_20170419_1004_B344392
> J9CL - 20170419_344392)
> JCL - 20170420_01 based on Oracle jdk8u131-b11
> 
> Where I get:
> 
> [ERROR] Failures:
> [ERROR]   TestSSLContextBuilder.testBuildAllDefaults:107
> expected:<[SunJSSE]> but was:<[IBMJSSE2]>
> [ERROR]   TestSSLContextBuilder.testBuildAllNull:124
> expected:<[SunJSSE]>
> but was:<[IBMJSSE2]>
> [ERROR]   TestSSLContextBuilder.testBuildWithProvider:185
> expected:<[SunJSSE]> but was:<[IBMJSSE2]>
> [ERROR]   TestSSLContextBuilder.testBuildWithProviderName:197
> expected:<[SunJSSE]> but was:<[IBMJSSE2]>
> [ERROR]   TestSSLContextBuilder.testSSLHanskshakeProtocolMismatch1
> 
> I do not have an app coded to the new API, so that's all I could
> test.
> 
> Note that I had to disable my Maven toolchain.xml file because on
> Java 8,
> the build was picking up Java 7's Javadoc and failing since Javadoc 7
> does
> not know about turning off doclint.
> 

I ran into this issue, too, but it was too late. It looks like profile
activation based on Java version and ToolChain plugin do not play
along. The easiest work-around for the issue is to disable lax-doclint
profile with

-P-lax-doclint

Oleg

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message