hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Freeman Fang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HTTPASYNC-97) OSGi: current http async not compatible with current http client
Date Mon, 13 Jun 2016 07:08:21 GMT

    [ https://issues.apache.org/jira/browse/HTTPASYNC-97?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15326911#comment-15326911
] 

Freeman Fang commented on HTTPASYNC-97:
---------------------------------------

Hi Oleg,

I'm -1 for this release.
Because the httpasyncclient-osgi bundle Import-Package org.apache.http.client.config with
wrong version.
It should be 
{code}
diff --git a/httpasyncclient-osgi/pom.xml b/httpasyncclient-osgi/pom.xml
index 32369cb..34566e6 100644
--- a/httpasyncclient-osgi/pom.xml
+++ b/httpasyncclient-osgi/pom.xml
@@ -107,7 +107,7 @@
             org.apache.http.conn.ssl;version=${httpclient.osgi.import.version},
             org.apache.http.conn.util;version=${httpclient.osgi.import.version},
             org.apache.http.client;version=${httpclient.osgi.import.version},
-            org.apache.http.client.config;version=${httpcore.osgi.import.version},
+            org.apache.http.client.config;version=${httpclient.osgi.import.version},
             org.apache.http.client.methods;version=${httpclient.osgi.import.version},
             org.apache.http.client.params;version=${httpclient.osgi.import.version},
             org.apache.http.client.protocol;version=${httpclient.osgi.import.version},
{code}

Will append a patch soon.

Thanks
Freeman

> OSGi: current http async not compatible with current http client 
> -----------------------------------------------------------------
>
>                 Key: HTTPASYNC-97
>                 URL: https://issues.apache.org/jira/browse/HTTPASYNC-97
>             Project: HttpComponents HttpAsyncClient
>          Issue Type: Bug
>            Reporter: Benson Margulies
>             Fix For: 4.1.2
>
>
> Any chance of a release to async that is compatible with 4.5 of the main client?
> {noformat}
> org.osgi.service.resolver.ResolutionException: Unable to resolve root: missing requirement
[root] osgi.identity; osgi.identity=rosapi-front-end-service; type=karaf.feature; version="[0.7.106.SNAPSHOT,0.7.106.SNAPSHOT]";
filter:="(&(osgi.identity=rosapi-front-end-service)(type=karaf.feature)(version>=0.7.106.SNAPSHOT)(version<=0.7.106.SNAPSHOT))"
[caused by: Unable to resolve rosapi-front-end-service/0.7.106.SNAPSHOT: missing requirement
[rosapi-front-end-service/0.7.106.SNAPSHOT] osgi.identity; osgi.identity=com.basistech.ws.rosapi-front-end-service;
type=osgi.bundle; version="[0.7.106.v20151229125335,0.7.106.v20151229125335]"; resolution:=mandatory
[caused by: Unable to resolve com.basistech.ws.rosapi-front-end-service/0.7.106.v20151229125335:
missing requirement [com.basistech.ws.rosapi-front-end-service/0.7.106.v20151229125335] rosapi-transport
[caused by: Unable to resolve com.basistech.ws.rosapi-front-end-anvils-transport/0.7.106.v20151229125333:
missing requirement [com.basistech.ws.rosapi-front-end-anvils-transport/0.7.106.v20151229125333]
osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.http.impl.nio.client)(version>=4.1.0)(!(version>=5.0.0)))"
[caused by: Unable to resolve org.apache.httpcomponents.httpasyncclient/4.1.1: missing requirement
[org.apache.httpcomponents.httpasyncclient/4.1.1] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.http.auth)(version>=4.4.0)(!(version>=4.5.0)))"]]]]
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message