hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Venkata Satya Teja Siram (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HTTPCORE-421) RouteSpecificPool timeout Occuring processing HTTP request while using NIO
Date Fri, 01 Apr 2016 20:13:25 GMT
Venkata Satya Teja Siram created HTTPCORE-421:
-------------------------------------------------

             Summary: RouteSpecificPool timeout Occuring processing HTTP request while using
NIO
                 Key: HTTPCORE-421
                 URL: https://issues.apache.org/jira/browse/HTTPCORE-421
             Project: HttpComponents HttpCore
          Issue Type: Bug
          Components: HttpCore NIO
         Environment: Centos machine 1 core,Some times simulatable on linux machine 4 core
            Reporter: Venkata Satya Teja Siram
            Priority: Critical


Hi Team,
We have a an application in which we are making an asynchronous request to get the response.For
making asynchronous Request we are using apache nio

Reference link followed:
https://hc.apache.org/httpcomponents-core-ga/tutorial/html/nio.html

While using this we are facing an issue.The issue is also not always simulatable.I was not
able to figure out the route cause.

The issue details are as follows:
java.net.ConnectException: null
        at org.apache.http.nio.pool.RouteSpecificPool.timeout(RouteSpecificPool.java:170)
[httpcore-nio-4.4.4.jar:4.4.4]
        at org.apache.http.nio.pool.AbstractNIOConnPool.requestTimeout(AbstractNIOConnPool.java:560)
[httpcore-nio-4.4.4.jar:4.4.4]
        at org.apache.http.nio.pool.AbstractNIOConnPool$InternalSessionRequestCallback.timeout(AbstractNIOConnPool.java:821)
[httpcore-nio-4.4.4.jar:4.4.4]
        at org.apache.http.impl.nio.reactor.SessionRequestImpl.timeout(SessionRequestImpl.java:182)
[httpcore-nio-4.4.4.jar:4.4.4]
        at org.apache.http.


Version being used:

<dependency>
			<groupId>org.apache.httpcomponents</groupId>
			<artifactId>httpclient</artifactId>
			<version>4.5.1</version>
		</dependency>


		<dependency>
			<groupId>org.apache.httpcomponents</groupId>
			<artifactId>httpcore-nio</artifactId>
			<version>4.4.4</version>
		</dependency>


Initially i thought issue was with pool and increased pool size(NIO Pool) while load testing.
But some times it occurs if a send single request only although pool size is 1000 ,the issue
is occurring.

Is this issue has something related to cpu core size, on 4 core processor its happening very
less and on single core processor it occurs very frequency
is more..For NIO reactor , we have given the default config.As the documentation specifies
the number of dispatcher threads would be dependent on number of cores on the system.

Any help regarding this issue?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message