hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Moore <j...@apache.org>
Subject Re: HC 5.0: package / module structure; Re: HC 5.0: co-location with HC 4.x
Date Sun, 22 Nov 2015 23:10:38 GMT
On Sat, Nov 21, 2015 at 1:56 PM, Michael Osipov <michaelo@apache.org> wrote:

> Am 2015-11-21 um 19:52 schrieb Gary Gregory:
>
>> +1.
>>
>> I would not mind using Java 8 too.
>>
>
> Believe that is too early. We are using a company-wide, Eclipse RCP-based
> product which is on Eclipse 3.4/3.6 and still HttpClient 3.x. I highly
> doubt that the dev team will jump on e4 and Java 8 features.
> Java 7 is a good base line.


Java 7 is already end-of-life, as of April 2015. Given that part of the
idea of starting version 5.0 is to be able to remove deprecated items and
general cleanup, it would seem prudent to me to at least *start* HC 5.0
with a non-EOL Java version. In addition, the Streams API that were added
to in java.util.streams might be very useful especially in an HTTP/2.0
implementation, although that might be a separate discussion.

I will also note that you should weigh my opinion against the fact that I
haven't had a lot of time for contributing recently...

Jon

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message