hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oleg Kalnichevski (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HTTPCORE-395) VersionInfo#getUserAgent reports incorrect Java version
Date Wed, 11 Feb 2015 10:54:11 GMT

    [ https://issues.apache.org/jira/browse/HTTPCORE-395?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14316022#comment-14316022
] 

Oleg Kalnichevski commented on HTTPCORE-395:
--------------------------------------------

> I haven't seen any client explicitly saying that he does not know the version

So what? HC has been doing that since 4.0. Even for the compatibility and consistency sake
changing this behavior in a bug fix release sounds questionable to me.

Oleg

> VersionInfo#getUserAgent reports incorrect Java version
> -------------------------------------------------------
>
>                 Key: HTTPCORE-395
>                 URL: https://issues.apache.org/jira/browse/HTTPCORE-395
>             Project: HttpComponents HttpCore
>          Issue Type: Bug
>          Components: HttpCore
>    Affects Versions: 4.4
>            Reporter: Michael Osipov
>            Assignee: Michael Osipov
>             Fix For: 4.4.1, 5.0-alpha1
>
>
> Currently {{VersionInfo#getUserAgent}} sets {{Java 1.5 minimum}} by default but both
[HttpCore|http://hc.apache.org/httpcomponents-core-4.4.x/httpcore/project-summary.html] and
[HttpClient|http://hc.apache.org/httpcomponents-client-4.4.x/httpclient/project-summary.html]
have Java 1.6 now. Values are completely ignored.
> This needs to be determined at runtime. The best approach would be add a manifest property
{{X-Compile-Target-JDK}} just like {{[commons-parent|http://svn.apache.org/viewvc/commons/proper/commons-parent/trunk/pom.xml?view=markup#l506]}}
does. {{VersionInfo}} can be changed and report that information.
> Alternatively, this information can be completely dropped.
> The output now is
> {noformat}
> [http-8081-1] DEBUG org.apache.http.wire - http-outgoing-44 >> "User-Agent: Apache-HttpClient/4.4
(Java 1.5 minimum; Java/1.7.0_55)[\r][\n]"
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message