hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jens Offenbach (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HTTPCLIENT-1527) httpclient-osgi incompatible to httpcore-osgi
Date Mon, 14 Jul 2014 14:28:05 GMT

    [ https://issues.apache.org/jira/browse/HTTPCLIENT-1527?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14060681#comment-14060681
] 

Jens Offenbach commented on HTTPCLIENT-1527:
--------------------------------------------

Of course... I am sorry.

Have a look to the pom.xml in the httpclient-osgi folder:
https://github.com/apache/httpclient/blob/trunk/httpclient-osgi/pom.xml

Line 43:
<httpcore.osgi.import.version>"[4.3.0, 4.4.0)"</httpcore.osgi.import.version>
->
<httpcore.osgi.import.version>"[4.4.0, 4.5.0)"</httpcore.osgi.import.version>


> httpclient-osgi incompatible to httpcore-osgi
> ---------------------------------------------
>
>                 Key: HTTPCLIENT-1527
>                 URL: https://issues.apache.org/jira/browse/HTTPCLIENT-1527
>             Project: HttpComponents HttpClient
>          Issue Type: Bug
>          Components: HttpClient
>    Affects Versions: 4.4 Alpha1
>            Reporter: Jens Offenbach
>              Labels: osgi
>
> The current state (4.4 Alpha1) of httpclient-osgi is incompatible to httpcore-osgi (4.4
Alpha1). Have a look to the manifest and its imported packages. The current state disallows
to import packages from httpcore-osgi in version 4.4 Alpha 1.
> Please fix!



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message