hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: Java 1.5 -> 1.6 or 1.7? was Re: java 1.5?
Date Tue, 25 Mar 2014 13:11:02 GMT
On Tue, 2014-03-25 at 08:17 -0400, Gary Gregory wrote:
> On Tue, Mar 25, 2014 at 7:48 AM, Dmitry Potapov <potapov.d@gmail.com> wrote:
> 
> > Gentlemen,
> >
> > Have you came to any conclusion concerning this?
> > Currently AbstractMultiworkerIOReactor.execute(...) has finally block which
> > calls doShutdown() which can throw exception itself (see HTTPCORE-376), so
> > all information about current exception will be lost.
> > One of the ways to fix this and have information concerning both exception
> > is
> > to use suppressed exceptions idiom implemented in Java 7 (probably with
> > conjunction with try-with-resources), so I wish to know is it allowed to
> > use
> > Java 7 features in future patches.
> >
> 
> I do not think this has come up. I would be OK with Java 7 for trunk. Oleg?
> 

I do not own HC. It is mainly an outlet for my personal frustration for
having to write horrible software at work. We can upgrade whenever you
folks feel like. But in my opinion we ought not do it for no reason.
This decision should be made in a context of a development road map or
some sort.

I dumped my personal plans here 
https://wiki.apache.org/HttpComponents/HttpComponentsRoadmap

We just upgraded HttpCore and HttpClient trunks to 1.6. I _personally_
think 1.7 upgrade could wait until 4.5. 

Oleg




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message