hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Strange behaviour with httpclient 4.2.6 / core 4.2.5
Date Wed, 19 Feb 2014 14:50:31 GMT
We're trying to investigate why disabling staleCheck in JMeter 2.11
should cause some requests to fail unexpectedly [1]


I have run a test, and I am seeing some odd log output:

2014/02/19 14:27:47:875 GMT [DEBUG] headers - >> Host: redacted
2014/02/19 14:27:48:171 GMT [DEBUG] DefaultClientConnection -
Receiving response: HTTP/1.1 302 Found

That was OK

next time round the loop:

2014/02/19 14:28:01:578 GMT [DEBUG] headers - >> Host: redacted
2014/02/19 14:28:01:578 GMT [DEBUG] DefaultClientConnection -
Connection 0.0.0.0:3715<->redacted:443 closed
2014/02/19 14:28:01:578 GMT [DEBUG] DefaultClientConnection -
Connection 0.0.0.0:3715<->redacted:443 closed
2014/02/19 14:28:01:578 GMT [DEBUG] DefaultClientConnection -
Connection 0.0.0.0:3715<->redacted:443 shut down
2014/02/19 14:28:01:578 GMT [DEBUG] BasicClientConnectionManager -
Releasing connection
org.apache.http.impl.conn.ManagedClientConnectionImpl@e1e74d

Why are there 3 copies of the same log message?
And why is the connection being closed?
The timestamp shows it happens immediately - there is probably not
time to actually contact the remote host.

The same sequence repeats another 3 times (there are 6 loops on the
test, alternate ones - 2,4,6 - fail on this one sample)
All other samples in the test work OK as far as I can tell.

Any ideas how to debug this further?

[1] https://issues.apache.org/bugzilla/show_bug.cgi?id=56119

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message