hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sukesh Kumar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HTTPCLIENT-1445) Unable to access WebService through WebSphere Application Server with new HttpClient
Date Mon, 06 Jan 2014 23:07:50 GMT

    [ https://issues.apache.org/jira/browse/HTTPCLIENT-1445?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13863594#comment-13863594
] 

Sukesh Kumar commented on HTTPCLIENT-1445:
------------------------------------------

Hi Oleg,
Thanks a lot for this code. This really helps. 
I am still unclear on how come we need this configuration for 4.2.5, whereas we do not need
it for 4.0. We were trying to avoid this specific configuration, as with the previous version.

 I will try to use the latest version. Will it be possible for you to guide on how to configure
the same on 4.3.1? 

> Unable to access WebService through WebSphere Application Server with new HttpClient
> ------------------------------------------------------------------------------------
>
>                 Key: HTTPCLIENT-1445
>                 URL: https://issues.apache.org/jira/browse/HTTPCLIENT-1445
>             Project: HttpComponents HttpClient
>          Issue Type: Bug
>          Components: HttpClient
>    Affects Versions: 4.2.6
>         Environment: OS- Windows
> Application Server- WebSphere Application Server 7.0.0.11
>            Reporter: Sukesh Kumar
>              Labels: httpclient, ssl, websphere
>
> Hi,
> My project needs to access a 2-way SSL WebService. 
> I am configuring WebSphere Application Server's (WAS) signer certificate to setup the
trust between my application's server and the external server hosting the webservice.  
> With HttpClient 4.0, I am successfully able to connect to the WebService and I get the
expected response. 
> When I change the HttpClient to 4.2.5, the server returns a 500 response. For the code
to work on new API, I have to write the code to use WAS alias, which I do not want to do.

> I expected the new version to work the same way as the old one. I am not sure what has
changed with this new version. Please help.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message