hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oleg Kalnichevski (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HTTPCLIENT-1400) Improve JCL logger compatibility of HttpClient OSGi bundle
Date Tue, 17 Sep 2013 08:28:53 GMT

     [ https://issues.apache.org/jira/browse/HTTPCLIENT-1400?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Oleg Kalnichevski resolved HTTPCLIENT-1400.
-------------------------------------------

    Resolution: Fixed

Implemented in SVN trunk. Please review / test.

Oleg
                
> Improve JCL logger compatibility of HttpClient OSGi bundle
> ----------------------------------------------------------
>
>                 Key: HTTPCLIENT-1400
>                 URL: https://issues.apache.org/jira/browse/HTTPCLIENT-1400
>             Project: HttpComponents HttpClient
>          Issue Type: Improvement
>          Components: HttpClient
>    Affects Versions: 4.3 Final
>         Environment: OGSi Framework
>            Reporter: Jens Offenbach
>             Fix For: 4.3.1
>
>
> The package-import org.apache.commons.logging;version="1.1.3" keeps me in trouble in
OSGi-based environments. I'am using SLF4J 1.7.5. which offers only the package in version
1.1.1. Based on the release history of JCL the API has not changed from 1.1.1 to 1.1.3. In
order to get a working version of your HTTP Client OSGi bundle, I had to change the imported
package version manually. This is not a satisfying solution.
> Use this instead and the problem is solved:
> org.apache.commons.logging;version="[1.1.1,1.2.0)"

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message