hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <garydgreg...@gmail.com>
Subject Re: Java 1.5 -> 1.6 or 1.7? was Re: java 1.5?
Date Sat, 14 Sep 2013 11:52:12 GMT
On Sep 14, 2013, at 7:23, Oleg Kalnichevski <olegk@apache.org> wrote:

> On Fri, 2013-09-13 at 17:25 -0400, Gary Gregory wrote:
>> HttpClient 4.2 and 4.3 requires Java 5.
>>
>> Which components are you talking about?
>>
>> Gary
>
> I think the question is whether or not we should retain 1.5
> compatibility for the next release series.
>
> I believe that 1.5 compatibility is becoming pointless. It is getting
> increasingly difficult to maintain while hardly helping us expand our
> user base. As far as know there is no even official way of obtaining a
> 1.5 JDK from Oracle.
>
> However having said all that I also have to admit that Java 1.6 does not
> really bring a lot in terms of new features. We probably should also
> consider upgrading straight to Java 1.7 in order to get full try with
> resources support and NIO2.
>
> I suggest that we take this discussion to the user list and start a poll
> on a minimal JRE level for the next release series.

It seems to me that 4.2.x and 4.3.x should stay on Java 5 and we can
go to 6 or 7 for 4.4.
>
> Oleg
>
>>
>> On Fri, Sep 13, 2013 at 2:37 PM, Ryan McKinley <ryantxu@gmail.com> wrote:
>>
>>> Now that a release is out, is it worth asking about 1.5 support?
>>>
>>> Obviously we should not change the system requirements unless there is a
>>> clear gain.
>>>
>>> Thoughts?
>>>
>>> ryan
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
> For additional commands, e-mail: dev-help@hc.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message