hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: [VOTE] HttpComponents Core 4.2.3 release based on RC1
Date Mon, 26 Nov 2012 16:38:50 GMT
On Mon, 2012-11-26 at 11:17 -0500, Gary Gregory wrote:
> -1: Either the build instructions are incomplete or there is build bug:
> 
> - download the tag
> http://svn.apache.org/repos/asf/httpcomponents/httpcore/tags/4.2.3-RC1/
> - Follow instructions in BUILDING.txt
> - This step: "mvn antrun:run" gives:
> 
> [INFO] HttpComponents Core ............................... SUCCESS [40.379s]
> [INFO] HttpCore .......................................... SUCCESS [0.297s]
> [INFO] HttpCore NIO ...................................... FAILURE [0.046s]
> [INFO] HttpCore OSGi bundle .............................. SKIPPED
> [INFO] HttpCore AB clone ................................. SKIPPED
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 42.817s
> [INFO] Finished at: Mon Nov 26 11:13:44 EST 2012
> [INFO] Final Memory: 16M/336M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal on project httpcore-nio: Could not resolve
> dependencies for project org.apache.httpcomponents:httpcore-nio:jar:4.2.3:
> Failure to
> find org.apache.httpcomponents:httpcore:jar:4.2.3 in
> http://repo.maven.apache.org/maven2 was cached in the local repository,
> resolution will not be reattempted
> until the update interval of central has elapsed or updates are forced ->
> [Help 1]
> [ERROR]
> 
> Is a step for "mvn install" missing?
> 

Yes, apparently 'mvn install' is required prior to this step. However,
it is not a release blocker in my option. 


> - This next step: mvn site
> -Dmaven.clover.licenseLocation=C:\Users\ggregory\Documents\Apache/clover.license
> - gives the error: Could not find resource* '/default-clover-report.xml'*
> 
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] HttpComponents Core ............................... SUCCESS [34.443s]
> [INFO] HttpCore .......................................... FAILURE [57.027s]
> [INFO] HttpCore NIO ...................................... SKIPPED
> [INFO] HttpCore OSGi bundle .............................. SKIPPED
> [INFO] HttpCore AB clone ................................. SKIPPED
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 1:32.798s
> [INFO] Finished at: Sun Nov 25 17:04:07 EST 2012
> [INFO] Final Memory: 59M/722M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-site-plugin:3.0:site (default-site) on
> project httpcore: Error during page generation: Error rende
> ring Maven report: Could not resolve default-clover-report.xml. Please try
> specifying this via the maven.clover.reportDescriptor property. Failed to
> load resour
> ce as file [/default-clover-report.xml]: Could not find resource
> '/default-clover-report.xml'. -> [Help 1]
> [ERROR]
> 
> Is this file missing from the tag or should it be generated?
> 

Clover plugin is not compatible with Maven 3. I believe we have already
discussed it

http://markmail.org/message/xlg6c3ywlf4pmol7

Oleg



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message