hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: HTTP Core problem with String Entity
Date Sun, 25 Mar 2012 19:10:20 GMT
On Sun, 2012-03-25 at 21:23 +0300, Dix_2007@ukr.net wrote:
> Hello.
> 
> I'm starting with Java and  HTTP Core.
> I've take the latest version of HTTP Core - alpha and then tested this
> situation also with latest stable version - behavior is the same:
> I've  tried  to deploy an example of simple Post that is provided with
> the  library.  I wiresharked my request and the body of my message was
> empty.  I was trying to solve this problem for number of hours, but it
> was  unsuccessfully.  After the execution of "process" or "preProcess"
> commands the body (entity) of the message becomes empty.
> For more details and sources - my pos on StackOverflow:
> http://stackoverflow.com/questions/9862044/httprequest-entitybody-is-empty-when-request-is-sent-using-java-httpcore
> 
> 

This problem is caused by a combination of two factors: the server not
handling the expect-continue handshake well and a regression in the 4.2
branch (fixed in SVN trunk [1]). 

Please upgrade to the latest SVN snapshot and re-test your application.

Cheers

Oleg 

[1]
http://svn.apache.org/viewvc/httpcomponents/httpcore/trunk/httpcore/src/main/java/org/apache/http/impl/AbstractHttpClientConnection.java?view=diff&r1=1305089&r2=1305090&pathrev=1305090


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message