hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis Rieks (JIRA)" <j...@apache.org>
Subject [jira] Created: (HTTPCLIENT-934) kerberos auth not working
Date Wed, 05 May 2010 18:06:03 GMT
kerberos auth not working
-------------------------

                 Key: HTTPCLIENT-934
                 URL: https://issues.apache.org/jira/browse/HTTPCLIENT-934
             Project: HttpComponents HttpClient
          Issue Type: Bug
          Components: Examples, HttpClient
    Affects Versions: 4.1 Alpha1
            Reporter: Dennis Rieks
            Priority: Minor


Hi,
i used org/apache/http/examples/client/ClientKerberosAuthentication.java to test kerberos
authentication.

My Setup:
Apache2 on Debian (virtual machine "server4.kdctest.local") is setup to deliver kerberos authenticated
content via http and https.
The Kerberos kdc (virtual maschine "kdc.kdctest.local") also runs on debian.
On my Desktop (ubuntu) i can use kinit/klist/kdestory to sign in on the kerberos domain and
server4 only delivers content when signed on. 
I used firefox (with extra settings for http in about:config) and curl (curl -k --negotiate
-u : http://server4.kdctest.local/test.php) to test my kerberos setup.

The Problem:
ClientKerberosAuthentication always asks the username/password and dont care about kinit.
Also there is always an http 401 error and no content is deliverd.



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message