hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [HttpCore] Java level 1.3 -> 1.5
Date Thu, 08 Apr 2010 19:31:35 GMT
On 08/04/2010, Oleg Kalnichevski <olegk@apache.org> wrote:
> Folks
>
>  How do you feel about upgrading minimal JRE level for HttpCore 4.1 from
>  1.3 to 5.0 provided it remains fully binary compatible with HttpCore
>  4.0?

1.3 is seriously deficient now.
1.4 is still adequate, but 1.5 offers useful performance and memory
model improvements.
1.5 would also make it easier to build core since nio needs 1.5.

I'm OK with requiring a minimum of 1.5 (or 1.4), but not 1.6 (yet).

However, I don't think this should be introduced in a minor release; I
think it needs a major release.

>  Oleg
>
>
>  ---------------------------------------------------------------------
>  To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
>  For additional commands, e-mail: dev-help@hc.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message