hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Httpcomponents Wiki] Update of "CodingConventions" by TonyPoppleton
Date Fri, 15 Jan 2010 19:39:19 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Httpcomponents Wiki" for change notification.

The "CodingConventions" page has been changed by TonyPoppleton.
http://wiki.apache.org/HttpComponents/CodingConventions?action=diff&rev1=4&rev2=5

--------------------------------------------------

   * Ensure the Apache copyright header is at the top of every class
   * Imports should be organized into blocks starting with "java", "javax", "org", "com" in
that order, and within each block should be sorted alphabetically (Note that Eclipse IDE does
this automatically for you)
   * Use camelCase naming convention for classes/methods/fields/variables
+  * All indentation should be done with 4 spaces; tabs should never be used
+  * Lines should be wrapped if it improves readability
   * The name of an "abstract" class should generally be prefixed with Abstract..., especially
if it is the base implementation of an interface
   * Use a single blank line to separate code when appropriate; there shouldn't be any more
than one consecutive blank line in any part of the code
   * Classes that are not explicitly designed for extension should be made final

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message