hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Asankha C. Perera" <asan...@apache.org>
Subject Re: SessionInputBuffer and SOCKET_BUFFER_SIZE
Date Mon, 24 Aug 2009 09:50:44 GMT
Hi Oleg
>> If I understand correctly the SOCKET_BUFFER_SIZE parameter specifies the
>> size of the SessionInputBuffer. However the SessionInputBuffer is simply
>> used to read the header of a http message (i.e. the request line and
>> http headers) - and never intended to read the entity body / payload.
> This is not entirely correct. The socket buffer is also used to read the body
> of chunk coded messages. 
>> If so is there any specific reason to call this parameter the
>> SOCET_BUFFER_SIZE which seems a misleading - or have I missed something?
> Maybe 'session buffer' would have been a better name. What would you call such
> a buffer?
Sorry, I missed noticing the use of it within the ChunkDecoder. I do not
think a rename is necessary, but maybe it would be good to include this
into the documentation so that users will know how it is being used and
not confuse it with something related to a socket


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message