hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: HttpParams rename??
Date Sat, 21 Jun 2008 14:27:32 GMT

How about a somewhat different approach?

(1) Leave HttpCore be for now
(2) Make the following changes in HttpClient
   * Introduce ClientConfig interface extending HttpParams
   * Rename all #getParams methods to #getConfig and change them to
     return ClientConfig
(3) Plan for API breakage in HttpCore around late 2009
   * Migrate HttpCore base to Java 5.0
   * Use generics all over
   * Rename HttpEntity#consumeContent to #finish
   * Rename HttpParams interface to HttpConfig

How does that sound?


To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org

View raw message