hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: Strange links on Component sites
Date Sun, 06 Jan 2008 13:23:47 GMT

On Sat, 2008-01-05 at 16:12 +0100, Roland Weber wrote:
> Hi Oleg,
> 
> in the grey horizontal navbar between the logos and the
> site content, there are duplicate links to HttpComponents
> for the component pages:
> 
> http://hc.apache.org/httpcomponents-core/index.html
> http://hc.apache.org/httpcomponents-client/index.html
> 
> The module pages have links to Apache and HttpComponents,
> but the HttpComponents link points to the component (core
> or client) rather than the HttpComponents main page.
> That's OK from a navigation point of view, but the link
> should probably have a different name then.
> 
> cheers,
>   Roland
> 

Roland

This _appears_ to have been caused by the way Maven's site descriptor
inheritance works (or is meant to work, actually). Apparently the site
plugin was unable to locate the project POM and therefore was unable to
generate the navigation links properly.  

The problem seems to have been solved by setting a relative path to the
project POM in the respective components POMs. I just redeployed the
site. Let's see what happens.

Oleg

> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
> For additional commands, e-mail: dev-help@hc.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org


Mime
View raw message