hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: requirements, dependencies, jdk...
Date Thu, 15 Nov 2007 20:23:24 GMT
Roland Weber wrote:
> Hi all,
> 
> I also think that changing the JDK requirement for HttpCore
> between the last alpha and first beta would be a case of
> very poor timing. Even if 1.3 compatibility becomes obsolete,
> there will always be mobile devices where the full J2SE is
> not available. We can reconsider the minimum requirements
> for HttpCore 4.1.
> 
> For HttpClient, I don't care about the minimum JDK level,
> as long as you don't expect me to learn Java 5 over night :-)
> 

Hi Roland

I personally do not, but we may eventually find j.u.concurrent quite 
useful in HttpConn.

I suggest the following course of actions:
(1) I'll run a poll on the minimal JRE requirement on the user list
(2) if JRE 1.5 gets a simple majority of user votes, I'll call for a 
formal vote on the dev list.
(3) simple majority of binding votes will finalize the decision.

Does this sound all right?

Oleg


> cheers,
>   Roland
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: httpcomponents-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: httpcomponents-dev-help@jakarta.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: httpcomponents-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpcomponents-dev-help@jakarta.apache.org


Mime
View raw message