hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roland Weber <ossf...@dubioso.net>
Subject Re: svn commit: r554367 - in /jakarta/httpcomponents/httpcore/trunk: ./ module-main/src/main/java/org/apache/http/protocol/ module-main/src/test/java/org/apache/http/protocol/
Date Mon, 09 Jul 2007 11:56:53 GMT
Hi Sebastian,

> But in theory, one still has to use something like Integer.MAX_VALUE
> to absolutely guarantee that the entry will be added at the end...

True. Now I remember why I wanted -1 to map to the end of the list.

> If you don't want to use a magic number, why not have an addAtEnd() method?

Because we already have too many methods in the interface to
manage two simple lists. *sigh*

Add constants AT_END to the interfaces?
Or the extra methods? Or leave it as it is?


To unsubscribe, e-mail: httpcomponents-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpcomponents-dev-help@jakarta.apache.org

View raw message