hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From balaji hari <to.haribal...@gmail.com>
Subject Re: NIO client fails on solaris
Date Fri, 06 Jul 2007 15:33:08 GMT

Oleg,

Thanks for getting back to us on this. Please find my repy below.


olegk wrote:
> 
> balaji hari wrote:
>> We are evaluating synapse1.0 which uses jakarta http core nio package to
>> forward incoming requests to application server
>>
>> We are facing a strange issue where synapse server is able to forward
>> request to jboss server in windows xp but not in solaris. When we digged
>> the
>> problem we found its with the NIO component.
>>
>> The example given in NIO module NHttpClient.java when executed from
>> solaris
>> box is able to talk to HTTP server / servlet container running in windows
>> but not solaris (not even local machine).
>>
>>   
> Balaji,
> 
> I am a little confused here. Are you saying the NIO client works fine on 
> Solaris when sending requests to a server running on Windows but for 
> some reason does not work in the same environment when sending requests 
> to a server running on another Solaris box? Am I getting it correctly?
> 
> ----------------------------------------------------------------------------------------------------
> 
> This is how results look like
> 
> 1. solaris -> windows - yes
> 2. windows -> solaris - yes
> 3. solaris -> solaris (localhost) - no (synapse and jboss server sitting
> on the same machine can't talk to each other)
> 
> Both  telnet and commons-httpclient worked under scenario 3.
> 
> ----------------------------------------------------------------------------------------------------
> 
> 
>> I found some issues related to this in Sun forum but can't find a
>> solution.
>>
>>
>> http://forum.java.sun.com/thread.jspa?forumID=256&threadID=420607
>> http://forum.java.sun.com/thread.jspa?forumID=4&threadID=293672
>>
>> Any help regarding this would be greatly appreciated.
>>
>>   
> 
> I looked at the links but it is still not clear to me what the cause of 
> the problem might be. I do have to say NIO has a reputation of not being 
> truly portable across different platforms. Do you know if the same 
> problem can be reproduced on OpenSolaris? I am afraid it is going to be 
> difficult for me to fix the problem if it cannot be reproduced on a 
> Intel based operating system available as a free download
> 
> --------------------------------------------------------------------------------------------------
> We are not able to do the testing as we don't have OpenSolaris
> installation or intel based solaris operating system. We have sparc based
> solaris system (which is widely used in production / staging).
> So, do you mean to say that you won't support HttpCore NIO components in
> SPARC based Solaris servers?
> --------------------------------------------------------------------------------------------------
> 
> Balaji
> 
>> Envoronment:
>>
>> Java Version 1.5.0.06 
>> jakarta-httpcore-4.0-alpha4
>> Solaris 5.9
>>
>>
>>
>>
>>
>>   
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: httpcomponents-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail:
> httpcomponents-dev-help@jakarta.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/NIO-client-fails-on-solaris-tf4032155.html#a11467454
Sent from the HttpComponents-Dev mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: httpcomponents-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpcomponents-dev-help@jakarta.apache.org


Mime
View raw message