hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: Using Chunked encoding
Date Fri, 12 Jan 2007 07:54:52 GMT
Asankha C. Perera wrote:
> Hi
>
> I am using HttpCore with NIO extensions and trying to use chunked 
> encoding for the response if the version is HTTP 1.1. However, it 
> seems that the last chunk does not get written back to the client..  
> The output sent back to the client is as follows
>
> HTTP/1.1 200 OK
> Content-Type: text/xml; charset=UTF-8
> Date: Fri, 12 Jan 2007 05:27:20 GMT
> Server: Synapse-HttpComponents-NIO/1.1
> Transfer-Encoding: chunked
> Connection: Keep-Alive
>
> 396
> <?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope 
> xmlns:wsa="http://www.w3.org/2005/08/addressing" 
> xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">...................</soapenv:Envelope>

>
>
> Where am I going wrong?
>
> thanks
> asankha
>
Hi Ashanka,

Can it be you are not calling ContentEncoder#complete()?

http://jakarta.apache.org/httpcomponents/httpcore/jakarta-httpcore-nio/xref/org/apache/http/nio/impl/codecs/ChunkEncoder.html#69

Oleg

>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: httpcomponents-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: 
> httpcomponents-dev-help@jakarta.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: httpcomponents-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpcomponents-dev-help@jakarta.apache.org


Mime
View raw message