hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: [HttpCore][HttpAsync][POLL] Java 1.5 dependency for HttpCore NIO and eventually HttpAsync?
Date Sun, 01 Oct 2006 18:43:25 GMT
On Sat, 2006-09-30 at 19:37 +0200, Roland Weber wrote:
> FYI, I've checked the Java requirements of a few other projects:
> 
> Synapse requires Java 1.4

Roland, et al

As far as I know Synapse folks opted for implementing their own HTTP
client. There is no point of sticking to Java 1.4 only because of
Synapse. At the same time dependency on Java 1.5 can render HttpCore
unusable for quite a few other projects, so going Java 1.5 may be a
little too aggressive. Let's see how things develop, and if the
management of home brewed concurrent primitives gets too expensive, we
can revisit this issue.

Cheers,

Oleg

> Axis requires Java 1.3, recommends Tomcat as platform
> Tomcat 5.5 requires Java 1.5, or needs a 1.4 compatibility package
> 
> We should try to restrict use of Java 1.5 to implementation classes
> and leave them out of the API. Maybe I'll split the Ant build process
> to compile API and implementation classes in two steps, so we can
> detect unwanted dependencies. One of these days, if time permits.
> 
> cheers,
>   Roland
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: httpclient-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: httpclient-dev-help@jakarta.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-dev-help@jakarta.apache.org


Mime
View raw message