hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bindul Bhowmik" <bindulbhow...@gmail.com>
Subject Re: HttpComponents + Maven + Eclipse
Date Sun, 19 Mar 2006 20:57:20 GMT
On 3/19/06, Oleg Kalnichevski <olegk@apache.org> wrote:
> On Sat, 2006-03-18 at 20:05 -0700, Bindul Bhowmik wrote:
> > Hello List,
> >
> > Anybody else here using Eclipse for their development?
>
> I am. I am not using the maven2 plug-in, though. I am not a very big fan
> of Maven in general

Me neither :-)

>
> >  I tried to
> > check out http-components' http-core module as an eclipse project. I
> > am using the maven2 plug-in for eclipse, and somehow even after I
> > enable the plug-in for the project, it is unable to get the
> > dependencies.
> >
> > The console has the following:
> > <console>
> >
> > 3/18/06 7:27:14 PM MST: Reading /http-core/pom.xml
> > 3/18/06 7:27:14 PM MST: Project build error POM
> > 'org.apache.jakarta.httpcomponents:httpcomponents' not found in
> > repository: Unable to download the artifact from any repository
> >
> >   org.apache.jakarta.httpcomponents:httpcomponents:pom:4.0-SNAPSHOT
> >
> > from the specified remote repositories:
> >   central (http://repo1.maven.org/maven2)
> >
> > </console>
> >
>
> Can it be the plug-in is unable to find the global HttpComponents
> pom.xml? I suspect one needs to check out the entire httpcomponents
> directory off the SVN trunk using command line svn client and manually
> set up individual modules in Eclipse.

Dropped the whole idea of using the m2 plugin. Rather went ahead with
a bit more manual work [1]. Checked out the entire HttpComponents and
ran 'mvn install' and the 'mvn -Declipse.downloadSources=true
eclipse:eclipse' on http-core and http-async (Those are the only two
modules with pom.xml at the moment). Then imported each module
individually into Eclipse.

Thanks for the pointer Oleg.

By the way, when I set up http-async and maven is establishing the
dependency on http-core I see a message on the console -

<console>
[INFO]
       Sources for some artifacts are not available.
       List of artifacts without a source archive:
         o org.apache.jakarta.httpcomponents:http-core:jar:4.0-SNAPSHOT
</console>

And the http-core dependency in http-async is coming without source
attachment. However, junit has source attachment. Something to change
in the pom.xml of http-core? (Please pardon my maven ignorance)

Bindul

>
> Oleg
>
>
> > I am thinking this might be some pom.xml related issue, as other
> > simple maven projects are working fine. I am using maven plug-in
> > version 0.0.5 with Eclipse version 3.1.2.
> >
> > Help or pointers would be appreciated.
> >
> > TIA
> > Bindul
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: httpclient-dev-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: httpclient-dev-help@jakarta.apache.org
> >
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: httpclient-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: httpclient-dev-help@jakarta.apache.org
>
>

[1] http://maven.apache.org/guides/mini/guide-ide-eclipse.html

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-dev-help@jakarta.apache.org


Mime
View raw message