hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 37550] - Fail to receive response when posting using HTTP/1.1 to a HTTP/1.0 proxy
Date Thu, 17 Nov 2005 22:30:22 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=37550>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=37550





------- Additional Comments From manningr@spamcop.net  2005-11-17 23:30 -------
Odi,

My goal was to read the status line and figure out from the response that 
I'm talking with a server that only supports HTTP/1.0 based on the status line
of the response.  I'd rather not assume the proxy only supports 1.0, since my
application depends on support for chunked transfer-encoding.  I believe the 
protocol supports the ability for 1.1 clients to figure out that the server
they are communicating with only supports 1.0 without requiring the client to 
first speak 1.0 to it.  Is that not correct?

Rob

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-dev-help@jakarta.apache.org


Mime
View raw message