hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Molettiere <pie...@axonstudios.net>
Subject Re: [POLL][RESULT] Minimal JRE requirement for HttpClient 4.0
Date Fri, 04 Feb 2005 00:00:59 GMT

On Feb 3, 2005, at 3:01 PM, Oleg Kalnichevski wrote:
> This is intended to be a poll, so every vote counts.

1.4 +1 for the same reasons I've seen others post: 1.5 adoption will be 
lagging 1.4 adoption in mainstream use for sometime. 1.4 is already 
advancing on this front, and has lots of nifty NIO stuff to leverage.

The Mac OS X example is a good one. Tiger will only support Java 1.4 
and 1.5 when it comes out, and Panther will always remain at 1.3 and 
1.4. Not that the Mac OS X user base is a huge percentage of the total 
http-client market, but Apple's decisions are shaped by the same 
development and testing realities which affect every large software 
project, whatever platform it runs on.

(Didn't vote earlier since I thought it was restricted to developers.)

--
Peter Molettiere
Senior Engineer
Truereq, Inc.
http://www.truereq.com/


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-dev-help@jakarta.apache.org


Mime
View raw message