hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roland Weber <ROLWE...@de.ibm.com>
Subject Re: [POLL] Minimal JRE requirement for HttpClient 4.0
Date Wed, 26 Jan 2005 08:09:19 GMT
Hi Oleg,

> I am +1 to try to keep http-common API Java 1.3 compatible. I would not
> worry about http-common-implIO and concentrate exclusively on NIO impl
> until some real J2ME demand materializes backed by a number of
> contributers.

That was my line of thought as well. The question remains whether we just
*try* to keep the API compatible, or whether we keep the API in a separate
component (or, technically, as a separate build target) so we can build
it against JDK 1.3 to verify the compatibility.
If we consider this a technical question, we can defer the answer until
the implementation begins. On the other hand, we could address it on a
component level in the High Level Component Architecture.

cheers,
  Roland

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message