hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Cottenceau ...@mnc.ch>
Subject Re: [POLL] Minimal JRE requirement for HttpClient 4.0
Date Thu, 20 Jan 2005 15:04:29 GMT
Oleg Kalnichevski <olegk 'at' apache.org> writes:

> Dear all
> 
> We would like to know the opinion of HttpClient users whether the next
> major release of HttpClient (4.0) should
> 
> [ ] stay compatible with Java 1.2
> [ ] be compatible with Java 1.3 and above
> [ ] be compatible with Java 1.4 and above
> [X] be compatible with Java 1.5 and above

Since both HttpClient version 2.x and 3.x are already fine tools
and can be used with older version of java, I think that new
development (4.x) should be based on latest and greatest tools
available, if they bring significant values (if 3.x is maintained
when severe bugs are discovered). When 4.x will be ready for
production use, there is no doubt java 1.5 will be ready for real
production use too. Java 1.5 brings a very significant step
forward for the language, and HttpClient code could benefit a lot
with reduced class-casts and more robust code due to generics and
enums.

-- 
Guillaume Cottenceau

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-dev-help@jakarta.apache.org


Mime
View raw message