hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject Re: [POLL] Minimal JRE requirement for HttpClient 4.0
Date Tue, 25 Jan 2005 12:09:02 GMT
On Tue, Jan 25, 2005 at 11:18:54AM +0100, Guillaume Cottenceau wrote:
> Oleg Kalnichevski <olegk 'at' apache.org> writes:
> 
> > I find many Java 1.5 features very tempting. The main reason I am
> > against going Java 1.5 at this point because it would render HttpClient
> > unusable on many micro platforms. I suspect J2ME may never have many 1.4
> > & 1.5 features.  
> 
> Do you have more on that? It seems that the latest and greatest
> buzz for new mobile phones is java applications (mostly games).
> It seems logical from a marketing standpoint that Sun backs that
> trend by supporting the evolution of J2ME, including new features
> etc. Is it a stupid idea? I don't know much about potential new
> constraints brought by 1.4/1.5 that would make it incompatible
> with micro platforms.
> 

I know little (next to nothing) about J2ME. It appears J2ME will never
be able to support non-blocking IO because that usually requires native
support for such oprations, which is not avaialble on all micro
platforms. I have found no mentioning anywhere on the web whether that
means no NIO altogether or just no Selector related classes. Anyways,
NIO may become a problem if HttpClient 4.0 were to run on J2ME without
modifications.

Oleg


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-dev-help@jakarta.apache.org


Mime
View raw message