hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17821] - 100-Continue Error
Date Thu, 28 Oct 2004 08:02:52 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=17821>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=17821

100-Continue Error

qinghe@public.xm.fj.cn changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
           Keywords|                            |FAQ
         OS/Version|Other                       |Windows XP
           Platform|Other                       |PC
         Resolution|FIXED                       |
   Target Milestone|2.0 Beta 1                  |3.0 Alpha 2
            Version|2.0 Final                   |3.0 Alpha 2



------- Additional Comments From qinghe@public.xm.fj.cn  2004-10-28 08:02 -------
I keep getting 100 Continue error. My work can't continue since I can't resolve 
this problem.

My code is:

        HttpClient httpclient = new HttpClient();        
        HttpState initialState = new HttpState();
        initialState.addCookies(cookies);
        httpclient.setState(initialState);            
	httpclient.getState().setCookiePolicy(CookiePolicy.RFC2109);
        PostMethod post = new PostMethod(url);
        post.setUseExpectHeader(false);
        post.setRequestBody(data);
        post.setRequestContentLength(totalLen);        
        int result = httpclient.executeMethod(post);

The full log is as following:

2004/10/28 15:35:35:375 CST [DEBUG] DefaultHttpParams - Set parameter 
http.protocol.expect-continue = false
2004/10/28 15:35:36:015 CST [DEBUG] header - >> "POST /Agent/General/login.asp 
HTTP/1.1[\r][\n]"
2004/10/28 15:35:36:015 CST [DEBUG] HttpMethodBase - Adding Host request header
2004/10/28 15:35:36:015 CST [DEBUG] HttpMethodBase - Default charset used: ISO-
8859-1
2004/10/28 15:35:36:015 CST [DEBUG] header - >> "User-Agent: Jakarta Commons-
HttpClient/3.0-alpha2[\r][\n]"
2004/10/28 15:35:36:015 CST [DEBUG] header - >> "Host: phs.healthinsurance-
asp.com[\r][\n]"
2004/10/28 15:35:36:015 CST [DEBUG] header - >> "Cookie: $Version=0; 
VisitorGuid=F4BD5A9A%2D5D3E%2D485C%2DBAD7%2DF54B200C8B27; $Path=/[\r][\n]"
2004/10/28 15:35:36:015 CST [DEBUG] header - >> "Cookie: $Version=0; 
SessionGUID=45ED6F7B%2DC899%2D435A%2D8947%2DEFE8BAE24FD6; $Path=/[\r][\n]"
2004/10/28 15:35:36:031 CST [DEBUG] header - >> "Content-Length: 38[\r][\n]"
2004/10/28 15:35:36:031 CST [DEBUG] header - >> "Content-Type: application/x-
www-form-urlencoded[\r][\n]"
2004/10/28 15:35:36:656 CST [DEBUG] header - >> "[\r][\n]"
2004/10/28 15:35:36:656 CST [DEBUG] HttpMethodBase - Default charset used: ISO-
8859-1
2004/10/28 15:35:36:656 CST [DEBUG] content - 
>> "password=paperworkafs&username=ehealthasf"
2004/10/28 15:35:36:656 CST [DEBUG] EntityEnclosingMethod - Request body sent
2004/10/28 15:35:37:281 CST [DEBUG] header - << "HTTP/1.1 100 Continue[\r][\n]"
2004/10/28 15:35:37:281 CST [DEBUG] header - << "Server: Microsoft-IIS/5.0[\r]
[\n]"
2004/10/28 15:35:37:281 CST [DEBUG] header - << "Date: Thu, 28 Oct 2004 
07:35:29 GMT[\r][\n]"
2004/10/28 15:35:37:281 CST [INFO] HttpMethodBase - Discarding unexpected 
response: HTTP/1.1 100 Continue
2004/10/28 15:35:37:406 CST [DEBUG] header - << "HTTP/1.1 200 OK[\r][\n]"
2004/10/28 15:35:37:406 CST [DEBUG] header - << "Server: Microsoft-IIS/5.0[\r]
[\n]"
2004/10/28 15:35:37:406 CST [DEBUG] header - << "Date: Thu, 28 Oct 2004 
07:35:29 GMT[\r][\n]"
2004/10/28 15:35:37:406 CST [DEBUG] header - << "Content-Length: 5216[\r][\n]"
2004/10/28 15:35:37:406 CST [DEBUG] header - << "Content-Type: text/html[\r]
[\n]"
2004/10/28 15:35:37:406 CST [DEBUG] header - << "Cache-control: private[\r][\n]"

The server always returns the same content of the login screen no matter what 
username/password I sent. Could anybody tell me how to resolve this problem?

Thanks

---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-dev-help@jakarta.apache.org


Mime
View raw message