hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Kalnichevski <ol...@apache.org>
Subject RE: [HttpClient 3.0alpha2] Trouble with Basic authentication overSSL through a proxy.
Date Thu, 28 Oct 2004 22:13:56 GMT
> I see from the wire trace you've included that you are successful.  I'm
> not sure it's the same kind of test though.  I am doing Basic
> authentication with the Apache server while it appears you are doing
> Digest.  I'm not sure if that makes a difference. 

To my knowledge it does not. Both schemes are handled similarly, as they
both involve one challenge and one response.

>  I am also not sure
> what kind of proxy I'm going through because I do not own it or have
> control over it.  

That's bad. If I do manage to reproduce the problem I may not be able to
fix it


> Just to be clear this is only one case that I need to support.  I will
> also need to support proxy authentication as well.
> 

Actually my test also included proxy authentication (successful and
unsuccessful)

[DEBUG] header - -<< "Proxy-Authenticate: Basic realm="squid"[\r][\n]"
...
[DEBUG] header - ->> "CONNECT testhost:443 HTTP/1.1"
...
[DEBUG] header - ->> "Proxy-Authorization: Basic Y3JhcDpjcmFw[\r][\n]"


> I'll keep trying different setups.  Is there anything else that maybe I
> missed in my configuration?  Is it possible for you to try using squid
> without authentication and add basic realm authentication on your Apache
> server?
> 

>>From what I know about HttpClient internals that should not make a
difference, but I'll try it nonetheless. Not today, though, as it is
really late here. 

Cheers,

Oleg


---------------------------------------------------------------------
To unsubscribe, e-mail: httpclient-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: httpclient-dev-help@jakarta.apache.org


Mime
View raw message