hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dale McIntosh" <dale...@san.rr.com>
Subject Re: Problems using AuthSSLProtocolSocketFactory to send Client Certificate in HTTPS session handshake
Date Sat, 25 Sep 2004 20:38:57 GMT
Sorry the log didn't get attached

    Dale
----- Original Message ----- 
From: "Dale McIntosh" <dalemac@san.rr.com>
To: <commons-httpclient-dev@jakarta.apache.org>
Sent: Saturday, September 25, 2004 1:26 PM
Subject: Problems using AuthSSLProtocolSocketFactory to send Client
Certificate in HTTPS session handshake


> I have been trying for quite a wile to get the
AuthSSLProtocolSocketFactory
> to send a client certificate and it  doesn't seem to be working. I am
> wondering if the server (Oracle single sign-on server) is requesting the
> client cert. When the request is made from a browser, the browser does
send
> the client cert. I have attached, my application, it is relatively simple
> and a debug log.  The debug options I used were -
> javax.net.debug="ssl,handshake,keymanager".
>
> I have looked at the debug log and I do not see a certificate request.
> However, when IE is used, IE sends a client certificate.
>
> Any help would be appreciated.
>
>             Thanks,
>             Dale McIntosh
>


----------------------------------------------------------------------------
----


> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
commons-httpclient-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail:
commons-httpclient-dev-help@jakarta.apache.org


Mime
View raw message