hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Johnson <sjohn...@mercury.com>
Subject Error on Oracle App Server Admin Page
Date Tue, 10 Aug 2004 17:06:51 GMT
Hi All,
 
I am getting slightly different, but similar results from 2 Oracle App Server Admin Pages.
 
Here are the links, they both use Basic authentication, as confirmed by the WIRE debug.
Also the HTTP Request looks identical from HTTPClient and IE when viewed in a sniffer.
In both cases the first request is missing the:
Authorization: Basic YWRtaW5pc3RyYXRvcjphZG1pbmlzdHJhdG9y
header line and the response is 401.
The second request includes this line and IE works with 200.
HTTPClient does not get any response headers, but gets these exceptions:
 
http://maximus.mercury.co.il:4003/webcacheadmin?SCREEN_ID=CGA.Site.Stats
<http://maximus.mercury.co.il:4003/webcacheadmin?SCREEN_ID=CGA.Site.Stats&ACTION=Show>
&ACTION=Show
org.apache.commons.httpclient.HttpRecoverableException:
org.apache.commons.httpclient.HttpRecoverableException: Error in parsing the status line from
the response:
unable to find line starting with "HTTP"
 
 
<http://localhost:8888/SiteScope/cgi/go.exe/SiteScope?page=adhocReport&monitors=2+oracle&account=administrator
&group=oracle&detailed=true> http://sunqa1:4000/webcacheadmin?SCREEN_ID=CGA.Site.Stats&ACTION=Show
org.apache.commons.httpclient.HttpRecoverableException: java.net.SocketException: Software
caused connection
abort: recv failed
 
Both requests look identical to me:
 
GET /webcacheadmin?SCREEN_ID=CGA.Site.Stats&ACTION=Show HTTP/1.1
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash,
application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
Accept-Language: en-us
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Host: sunqa1:4000
Connection: Keep-Alive
Authorization: Basic YWRtaW5pc3RyYXRvcjphZG1pbmlzdHJhdG9y
 
The only thing that looks different in the sniffer is the client port.
HTTPClient uses the same client port for both requests, without and with Authorizaiton:
IE uses different ports on each request.
 
I didnt find anything in old bugs.
 
Thanks for you help,
Steve
 
Steve Johnson
Software Engineer
Mercury Interactive
720 564 - 6532
USA, Canada and the Americas 
720 564-6620
Hours: M-F 08:00-17:00 MST (Mountain Standard Time) 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
 <http://www.mercuryinteractive.com> http://www.mercuryinteractive.com
Looking for Answers to your SiteScope or SiteSeer questions?        <http://support.mercuryinteractive.com>
http://support.mercuryinteractive.com
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
 
 
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message