hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ortwin Glück <ortwin.glu...@nose.ch>
Subject Re: Bug in HTTPUrl?
Date Fri, 02 Apr 2004 14:40:53 GMT
It seems that the problem is in URI.java line 1886 that does not like 
meta characters in the userinfo. Should we be escaping the userinfo 
somehow (?) before passing the string to URI?

Odi

Gustav Munkby wrote:

> 
> hi,
> 
> If I do:
> 
> HTTPUrl url = new HTTPUrl("kurt", "nicepass#", hostname, 80, path);
> 
> throws a URIException with message "port number invalid".
> 
> First of all the message is wrong...
> 
> Next attempt was to urlencode the password, which resulted in the above 
> line working, but the password was sent url-encoded to the destination, 
> which can hardly be the desired behaviour?
> 
> regards,
> Gustav Munkby
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: 
> commons-httpclient-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: 
> commons-httpclient-dev-help@jakarta.apache.org

-- 
  _________________________________________________________________
  NOSE applied intelligence ag

  ortwin glück                      [www]      http://www.nose.ch
  software engineer                 [email] ortwin.glueck@nose.ch
  hardturmstrasse 171               [pgp id]           0x81CF3416
  8005 zürich                       [office]      +41-1-277 57 35
  switzerland                       [fax]         +41-1-277 57 12

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-httpclient-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-httpclient-dev-help@jakarta.apache.org


Mime
View raw message